Carte Chat Mauve Eve (problème composante couleur) [Réglé]

Apple 1, ][, //, IIGS ou /// et 4

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10366
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Carte Chat Mauve Eve (problème composante couleur) [Réglé]

Message par Fabrice Montupet » 16 févr. 2016 01:39

Je me penche actuellement sur une carte Chat Mauve Eve dont le signal bleu pose problème. Si je mets les potentiomètres rouge et vert à 0 et le bleu au maximum, le bleu apparait bien à l'écran mais dès que les 3 potentiomètres sont tous aux max, le bleu apparait vert. Par contre, le blanc s'affiche bien blanc. Tout porte à croire que le problème vient de la logique de traitement de la palette RVB. Je croise les doigts pour que le PLA soit OK. Les résistances et potentiomètres ont été vérifiés par acquis de conscience.
Aussi, j'aimerais savoir si un schéma de la carte est disponible, cela m'aiderait bien :)

Avatar de l’utilisateur
amauget
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 77
Inscription : 04 mai 2011 11:38
Localisation : Nantes

Re: Carte vidéo Chat Mauve Eve (recherche de panne)

Message par amauget » 16 févr. 2016 23:13

Bonsoir Fabrice,

J'ai farfouillé partout dans mes atchives : aucune trace de schéma.
Et le manuel ne nous aide pas beaucoup.
Antony
Apple II forever

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10366
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Carte vidéo Chat Mauve Eve (recherche de panne)

Message par Fabrice Montupet » 17 févr. 2016 00:38

Je te remercie d'avoir cherché!
Idem de mon côté, je n'ai rien trouvé. Il me reste à virer les composants (heureusement qu'ils sont tous sur supports) et à tracer le PCB afin de comprendre comment le bleu est traité. J'ai bien testés les circuits LS avec un testeur de CI mais je ne lui accorde qu'une confiance limitée. Il est déjà arrivé qu'il me donne un circuit OK alors qu'il était défectueux.

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10366
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Carte vidéo Chat Mauve Eve (recherche de panne)

Message par Fabrice Montupet » 17 févr. 2016 02:05

Bon, j'avance :)
Image
Mais le vert est pâle... :/
A suivre!

Avatar de l’utilisateur
rene
El Presidente
El Presidente
Messages : 1113
Inscription : 16 mai 2002 20:08
Localisation : Toulouse
Contact :

Re: Carte vidéo Chat Mauve Eve (recherche de panne)

Message par rene » 17 févr. 2016 10:30

C'est surement l'esprit de Woz qui a frappé
René

Avatar de l’utilisateur
FlyingNono
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1235
Inscription : 05 déc. 2003 21:26
Localisation : (encore dans les cartons)

Re: Carte vidéo Chat Mauve Eve (recherche de panne)

Message par FlyingNono » 17 févr. 2016 17:55

salut,
Fabrice Montupet a écrit :Bon, j'avance :)
C'était quoi ?
Fabrice Montupet a écrit :Mais le vert est pâle... :/
Sur la photo, ce n'est pas choquant, regarde les signaux au scope en sortie de carte à vide et raccordés, ont-ils des amplitudes identiques ?
a+
« Fluctuat nec mergitur. »

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10366
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Carte vidéo Chat Mauve Eve (recherche de panne)

Message par Fabrice Montupet » 18 févr. 2016 00:01

J'ai remplacé le 74LS10 situé sous la série de résistances. Mais des problèmes persistent: le vert foncé et le bleu foncé sont trop clairs, le violet tire sur le rouge. Bref, il manque encore du bleu.

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10366
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Carte vidéo Chat Mauve Eve (recherche de panne)

Message par Fabrice Montupet » 18 févr. 2016 01:35

... Carte Eve réparée :)
J'ai remplacé un des deux 74LS399 (le plus à droite de la carte) est voici le résultat:
ImageImage
ImageImage
ImageImage

Avatar de l’utilisateur
meridian
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 623
Inscription : 29 oct. 2014 06:08
Localisation : Seine-Saint-Denis

Re: Carte Chat Mauve Eve (problème composante couleur) [Rég

Message par meridian » 18 févr. 2016 01:55

Bravo :D

Avatar de l’utilisateur
fabu
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1333
Inscription : 16 oct. 2003 22:54
Localisation : Aveyron

Re: Carte Chat Mauve Eve (problème composante couleur) [Rég

Message par fabu » 18 févr. 2016 12:20

Beau travail Fabrice!
Je recherche du soft C64,Amstrad,Amiga,Msx

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10366
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Carte Chat Mauve Eve (problème composante couleur) [Rég

Message par Fabrice Montupet » 18 févr. 2016 16:00

Je vous remercie ! :)
Cette carte méritait une réparation, elle est fantastique! Une belle réussite française.
Ce que j’apprécie avec "Eve", c'est sa réalisation à base de circuits logiques standards. Elle peut ainsi être aisément réparée. Ce qui n'est malheureusement pas le cas de sa dauphine "Féline" qui embarque un circuit intégré prédiffusé, propriétaire et difficilement remplaçable de nos jours.

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7463
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Carte Chat Mauve Eve (problème composante couleur) [Rég

Message par jvernet » 18 févr. 2016 21:09

Ce qui serait pas mal, c'est d'avoir quelques mires pour se rendre compte si la carte fonctionne corectement ou pas.

Bon, pour ma part, j'utilise une Feline (mais j'ai aussi 2 EVE dans leurs cartons).


JV
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10366
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Carte Chat Mauve Eve (problème composante couleur) [Rég

Message par Fabrice Montupet » 20 févr. 2016 00:32

Les couleurs sont OK. J'ai écrit un petit programme pour afficher la palette 16 couleurs, voici le résultat sur
- Un moniteur TFT VGA couplé avec une GBS8220:
Image
- Un moniteur CRT Taxan RGB Vision II (programme modifié pour mieux voir la palette):
Image
Les photographies ont été prises avec un iPad 3 en conditions de luminosité ambiante faible.
En vrai, les couleurs rendent encore mieux.

farvardin
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 398
Inscription : 18 mai 2009 00:06
Contact :

Re: Carte Chat Mauve Eve (problème composante couleur) [Rég

Message par farvardin » 23 févr. 2016 10:08

Ça rend bien sur les copies d'écran... les couleurs ne sont pas trop criardes (contrairement au ZX Spectrum) ni trop ternes (contrairement au C64).

Sympa cette carte (tout comme le nom). Je ne connais pas du tout l'univers Apple, je ne savais même pas que l'on pouvait trouver ce type de carte d'extension (il y avait un port d'extension sur C64, Sinclair, même Atari ST mais ce n'était pas à l'intérieur).

Il existait même des copies pirates de cette Eve :
http://www.hackzapple.com/ORG1/MZ/PIRATEKARTES.HTM#EVE

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7463
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Carte Chat Mauve Eve (problème composante couleur) [Rég

Message par jvernet » 23 févr. 2016 13:04

Fabrice Montupet a écrit :Les couleurs sont OK. J'ai écrit un petit programme pour afficher la palette 16 couleurs, voici le résultat sur
- Un moniteur TFT VGA couplé avec une GBS8220:
Image
- Un moniteur CRT Taxan RGB Vision II (programme modifié pour mieux voir la palette):
Image
Les photographies ont été prises avec un iPad 3 en conditions de luminosité ambiante faible.
En vrai, les couleurs rendent encore mieux.
je sais que je devrais pouvoir faire la même chose, mais si tu as ton programme sous la forme d'une image disque, je veux bien.
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Répondre

Revenir vers « Apple 8 et 16 bits »