Emulateur

Tout sur le micro français le plus ambitieux mais si malchanceux

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
gatesbillou
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 60
Inscription : 06 oct. 2005 23:48

Message par gatesbillou » 05 nov. 2007 20:02

Désolé pour le retard , je m'était engagé a extraire la rom mais j'ai un probleme de cable serie que j'ai prété ... bref !
dès que je l'ai j'utilise donc ce programme :
10 OPEN #2,"10.B=9,N=8,S=1,P=0"
20 CALL POKE(49161,213,22,140,125,126)
30 FOR A=512 TO 65535
40 CALL PEEK(A,B)
50 PRINT #2,A,B
60 NEXT A
70 PRINT #2,"FIN DU DUMP"
80 CALL POKE(49161,140,109,8,140,0)
90 CLOSE #2
100 CALL POKE(49161,140,109,8,140,0,0)

En le modifiant pour extraire la rom interne qui est de F806 à FFFF ok?

Torlus
Administrateur
Administrateur
Messages : 1269
Inscription : 15 oct. 2005 22:33
Contact :

Message par Torlus » 05 nov. 2007 20:24

Tu peux le laisser tel quel et dumper l'ensemble, ça ne mange pas de pain. Comme ça on aura en plus le dump de la cartouche du Basic, ça permettra d'aller plus loin dans l'émulation ;)
"Pour finir, faut commencer."
"Il faut être un peu félé pour laisser passer la lumière".

Avatar de l’utilisateur
romualdl
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1987
Inscription : 23 mai 2002 15:44
Localisation : Beaumont Sur Oise (95)
Contact :

exl

Message par romualdl » 05 nov. 2007 21:48

salut,

J'ai déjà le dump de la cartouche basic...
;)
Je mets tout ca en ligne ce soir (pour la rom faudra attendre ce weekend si ce n'est pas fait d'ici là).

A+
ROmu
<Pocket>la striole en a un et il me le montre quand j'ai envie (irc-25/09/2008)

Avatar de l’utilisateur
romualdl
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1987
Inscription : 23 mai 2002 15:44
Localisation : Beaumont Sur Oise (95)
Contact :

roms

Message par romualdl » 05 nov. 2007 22:02

salut,

Dumps envoyés à Gilles.


A+
Romu
<Pocket>la striole en a un et il me le montre quand j'ai envie (irc-25/09/2008)

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3127
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Message par gilles » 08 nov. 2007 16:53

un peu de news....
Tout d'abord assez peu de temps de dispo pour cause de recherche (relativement) active d'emploi (... qui est très probablement trouvé maintenant, confirmation attendue demain).
Concernant un proto d'ému le code de MESS est assez spécifique et très adhérent à la structure de MAME, la remise en forme prend un peu plus de temps que prévu mais on devrait pouvoir exécuter du code sous debugger d'ici qqs jours.

Avatar de l’utilisateur
gatesbillou
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 60
Inscription : 06 oct. 2005 23:48

Message par gatesbillou » 08 nov. 2007 20:09

Bravo romuald; rapide et efficace.

Pour des raison perso je ne laisse pas le lien du desassembleur TMS7000 sur ce forum , merci de me contacter pour le recuperer.

gatesbillou at hotmail point com

Avatar de l’utilisateur
romualdl
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1987
Inscription : 23 mai 2002 15:44
Localisation : Beaumont Sur Oise (95)
Contact :

exl

Message par romualdl » 11 nov. 2007 22:05

salut,

Bon après recherche je n'ai plus de exeltel et pour le exl100 ya pas de port série (faut le module) donc j'ai pas pu dumper (j'ai eu la flemme de faire wav du dump de la rom). S'il faut (cad que personne n'a un moyen plus rapide) je pourrais le faire mais bon...

A+
Romu
<Pocket>la striole en a un et il me le montre quand j'ai envie (irc-25/09/2008)

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7814
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Message par jvernet » 11 nov. 2007 23:02

J'ai tout ce qu'il faut, sauf le temps pour le faire....
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3127
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Message par gilles » 11 nov. 2007 23:15

Il serait effectivement utile assez rapidement d'avoir le code de la rom interne. Je pense que d'ici demain un debugger primitif permettra de faire tourner le code du TMS7020 de mame.
On peut essayer de trouver un point d'entrée sur un dump de cartouche de jeu en espérant qu'il y ai peu d'appels moniteurs mais je n'y crois pas trop.

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3127
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Message par gilles » 12 nov. 2007 08:33

Le projet SourceForge est créé:

http://sourceforge.net/projects/exl100

Il est donc possible d'utiliser les forums correspondant et le bugtracker.
Je mettrais les premiers fichiers d'ici ce soir probablement.

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3127
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: exl

Message par gilles » 12 nov. 2007 13:20

romualdl a écrit :salut,

Bon après recherche je n'ai plus de exeltel et pour le exl100 ya pas de port série (faut le module) donc j'ai pas pu dumper (j'ai eu la flemme de faire wav du dump de la rom). S'il faut (cad que personne n'a un moyen plus rapide) je pourrais le faire mais bon...

A+
Romu
Je pense avoir trouvé un dump de rom 7020 sur le site http://miniordi.free.fr
reste à remettre en forme et à tester mais cela semble cohérent.

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3127
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Message par gilles » 13 nov. 2007 15:16

Un bout d'émulateur commence à tourner...
mais il plante après quelques boucles sur un dépassement de pile et se retrouve sur une adresse incorrecte.

Avatar de l’utilisateur
gatesbillou
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 60
Inscription : 06 oct. 2005 23:48

Message par gatesbillou » 13 nov. 2007 18:12

Si on peut t'aider fait signe :roll:

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3127
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Message par gilles » 13 nov. 2007 19:12

gatesbillou a écrit :Si on peut t'aider fait signe :roll:
absolument, va voir dans ta boite mail (celle sur hotmail).

Avatar de l’utilisateur
gatesbillou
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 60
Inscription : 06 oct. 2005 23:48

Message par gatesbillou » 13 nov. 2007 21:50

Très très très impressionant ! quel debut! un debugger tms7000 8O .

Tous les membres du forum sont avec toi, t'a qu'a faire signe. :D

ps : Si ca ce trouve ton projet va paraitre dans "exelement votre - hors série" :wink:

Répondre

Revenir vers « Exelvision »