zx81 video -> hdmi

Tous les Sinclair. Du Mk14 au QL

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
carlou
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 396
Inscription : 28 juin 2008 19:24
Localisation : Pessac

zx81 video -> hdmi

Message par carlou » 19 nov. 2019 01:51

Bonjour tout le monde, cela faisait bien longtemps que je ne m’étais pas remis sur une vielle bécane par manque de temps/envie.
Mais c'est chose faite vu que j'ai décidé de me relancer sur zx81 :)

Par contre, n'ayant pas de tv, ni un vieux moniteur, je me suis retrouvé confronté à un problème : Comment afficher sur un écran de pc le zx?
Il y a presque 10 ans, j'avais fait la modif pour passer le zx en composite donc je me suis dis qu'avec mon convertisseur scart / hdmi, cela fonctionnerait surement!
J'utilise ce type d'adaptateur : La bible atari que j'ai modifié pour mes ataris sur lequel j'ai mis un inverseur pour revenir à l’état d'origine.

Jusqu’à présent, je n'ai jamais eu de soucis avec. Atari, amiga, playstation et autres sources vidéos passent sans problème mais pas le zx :(

Symptômes :
En mode convertisseur d'origine -> image correct mais qui flashe. Elle apparait brièvement (même pas 1/2 seconde) puis disparait et le convertisseur cherche comment il doit se connecter.

En mode convertisseur avec modif atari -> écran noir

J'ai passé 2 semaines à chercher dans tous les sens, refait la modif vidéo du zx au propre, tenté le montage à base de lm1881, envoyé 5v sur la commutation lente et rapide péritel, rien à faire...

Et! A force de fouiner les forums, je suis tombé sur une discussion qui n'avait strictement rien à voir, si ce n'est un souci de vidéo et une des personne disait de relier la broche 20 (video in) et la broche 7 (entrée bleu) de la péritel.

Je ressort donc le fer a souder et comme je suis pas contrariant, je relie la broche 20 à la broche 11 (entrée verte). Souvenir surement de mon premier moniteur monochrome vert ^^

Et bingo! En mode "atari" sur le convertisseur (qui rajoute la commutation rapide) une belle image bien nette apparait! Bon en vert bien sur...

J'attends quand même un autre convertisseur rca / hdmi pour tester, mais dans le pire des cas, j'ai une solution d'affichage. Et si cela peut servi à d'autre, tant mieux :)

Reste maintenant à fabriquer un clavier pour la bestiole, j'ai cassé la nappe en le démontant et j'ose pas remonter la 2eme que j'ai.. Du coup je réfléchis à faire un clavier externe.
Je me suis aussi fabriqué un tzxduino pour le fun et j'aimerais bien le tester :)
Une fois tout bien câblé, je vais essayer d'apprendre à programmer en assembleur et gérer le port I/O pour faire des interfaces

Bonne soirée à tous!
"Faut essayer, on ne sait jamais!"

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3056
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: zx81 video -> hdmi

Message par gilles » 19 nov. 2019 09:34

je suppose qu'en mode composite il essaye de balayer tous les modes couleur (PAL secam NTSC et variantes) qu'il connaît et finit par boucler car il n'en trouve aucun. Au pire en connectant le bleu et le rouge en plus ça doit donner une image N&B avec la modif atari. en tout cas c'est bon à savoir ;)

Avatar de l’utilisateur
carlou
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 396
Inscription : 28 juin 2008 19:24
Localisation : Pessac

Re: zx81 video -> hdmi

Message par carlou » 19 nov. 2019 14:19

Je viens de recevoir le convertisseur cvbs -> hdmi, l'image est présente mais à un effet de sautillement régulier. L'effet inverse d'avant quoi a une fréquence plus élevée.
Ce soir je vais essayer en reliant rvb sur la péritel, merci Gilles, c'est tout bête mais je n'y avait même pas pensé ^^
Edit : Je confirme, cela marche impec en reliant RVB! (broches 7, 11, 15 et 20 donc de la peritel
"Faut essayer, on ne sait jamais!"

Répondre

Revenir vers « Sinclair »