Divers bricolages sur ZX81

Tous les Sinclair. Du Mk14 au QL

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 316
Inscription : 06 sept. 2016 13:16

Divers bricolages sur ZX81

Message par MapommeCMOA » 18 août 2018 01:42

Bonjour tous.
Je continue à poster dans cette rubrique. Je pense que c'est plus normal que de squatter l'autre. ( début de discutions )

Bonjour bernouilli92
bernouilli92 a écrit :
18 août 2018 00:45
@MapommeCMOA: Je suppose qu’au final tu auras quelque chose dans ce genre là :
www.ebay.fr/itm/132742815020


Ouaip, ça devrait ressembler à ça. J'ai vu ce clavier sur la bay, mais il doit être plus grand que le clavier d'origine. Je me suis tâté pour le prendre mais il manque des cabochons et avec le port + les enchères et le change, ça ne m'allait pas du tout.
Les touches doivent être de meilleur qualité que mes "chinoises. Ça ressemble bien à du Cherry.

Avatar de l’utilisateur
MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 316
Inscription : 06 sept. 2016 13:16

Re: Divers bricolages sur ZX81

Message par MapommeCMOA » 07 déc. 2018 21:04

Bonjour tous

Petite expérience toute simple sur ZX 81. Ça ne vole pas haut, mais c'est à mon niveau.
Jusqu'à maintenant, pour mes essais de safépu, j'utilisais un petit téléviseur cathodique d'ancienne génération. L'un d'eux m'a d'ailleurs lâché peu de temps après son réveil lors d'un essai. Comme je pense que celui encore valide risque de tomber en panne à son tour (pis c'est lourd et encombrant), j'ai fait un test sur un petit téléviseur à écran LCD avec décodeur TNT ancienne génération avec prise SCART et entrée composite RCA. Comme prévu, ça ne fonctionne pas. Il y a bien une image, mais elle n'est pas stable et brouillée. Un peu comme lors de problèmes de synchro "dans l'temps", sur les anciennes télés. Il y avait un potar à l'arrière, qui permettait de régler le problème. Maintenant, il n'y a plus de réglage de synchro.
Aujourd'hui, j'ai fait un nouvel essai en branchant mon ZX81, (qui a toujours les tripes à l'air) sur un lecteur enregistreur de DVD avec disque dur (qui n'est pas tout jeune non plus) avec plusieurs entrées vidéo.
Le ZX81 sur une entrée AV (vidéo composite) et la petite télé sur la prise péritel de l'enregistreur. Résultat : Image parfaitement stable.
Je vais vérifier si ça fonctionne aussi avec un APPLE II, l'ATARI ou autre. Je suis persuadé que ça marchera.
Petit avantage: L'enregistrement d'une vidéo est possible.
Inconvénient: L'enregistreur avec la petite télé LCD, prennent un peu de place.
Précision. L'enregistreur est un LG "SUPER MULTI" RH 188S. La marque ne doit pas avoir grande d'importance.
Peut être qu'en utilisant un magnétoscope ça serait bon aussi ?
Existe-t-il un petit circuit, si possible universel, qui permet de rendre les sorties vidéo des "vieux trucs", compatibles avec l'entrée vidéo des écrans récents ?
J'ai vu que des essais avaient déjà été faits ici, mais pas vraiment très concluants.

nicolho
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 14 sept. 2018 02:06

Re: Divers bricolages sur ZX81

Message par nicolho » 08 déc. 2018 16:33

Bonjour, je viens de chercher un peu, c'est un apparemment un problème bien connu avec les premiers modèles de ZX81 équipés du circuit ULA C184, si c'est le modèle que tu as. Pour expliquer, d'abord un peu de culture générale, et ces quelques explications du regretté André Ducros :
video ligne noir et blanc.jpg
source : http://f5ad.free.fr/ATV-QSP_F5AD_Le_signal_video.htm
video ligne noir et blanc.jpg (26.01 Kio) Consulté 420 fois
Cette figure représente le signal électrique correspondant à une ligne de télévision monochrome (noir et blanc), il varie de 0 à 1 Volt ; la partie comprise entre 0,3V et 1V détermine la luminosité du spot : en fait, quand le signal est inférieur à 0,375V le spot est noir (éteint) ; quand il est à 1Volt, le spot est blanc (luminosité maximale) entre 0,375 et 1 V il est gris plus ou moins foncé suivant la tension.

La ligne représentée à droite, dite en escalier, commence par une plage blanche puis par une gris clair puis par une plus foncée, pour arriver jusqu'au noir ; si toutes les lignes de l'image sont identiques à celle ci, on obtient une mire de barres.

La zone BC à 0,3V sert au téléviseur à repérer son niveau du noir, on l'appelle aussi zone de blanking ou niveau d'infra noir. De même pour la zone DA'.
Cette partie du signal, dénommée également palier de suppression (et aussi "palier arrière", équivalent de back porch en anglais) située entre B et C (à 0,3V) et qui suit immédiatement la pulsation de synchronisation horizontale (qui débute chaque ligne, représentée sur la figure entre A et B, à 0V) va permettre au récepteur de régler la luminosité, en considérant que le niveau de noir se situe légèrement plus haut (à 0,375V).

Le problème du signal vidéo de ces premiers ZX81 est qu'il ne comporte pas ce niveau intermédiaire back porch, ce qui peut soit troubler le décodeur du téléviseur (car pas dans la norme) soit qu'il se base sur un "noir" trop élevé, faisant alors disparaitre tout ou partie de l'image.

On voit ci-dessous la différence entre le signal vidéo d'origine du ZX81 (en bleu) sans back porch, et le même signal où il a été ajouté (en jaune) :
signal vidéo ZX81 sans puis avec back porch.jpg
signal vidéo ZX81 sans puis avec back porch.jpg (35.83 Kio) Consulté 420 fois
Cette vue d'oscilloscope est tirée d'une excellente vidéo explicative (pour ceux qui comprennent l'anglais et auraient quelques bases en électronique) : https://www.youtube.com/watch?v=1irH3KuGyl0
Son auteur présente à la fin un petit circuit correctif assez simple qui sert à rajouter le back porch au signal, en sortie du circuit ULA du ZX81 (et qui utilise pour ce faire le "couteau-suisse" des composants, le NE555) qu'on doit même pouvoir réaliser sans soudure (sur platine d'essai ou même sans). En plus de la vidéo, tout est détaillé dans ce document : http://zx.zigg.net/misc-projects/ZX81_V ... ioning.pdf

Il existe également d'autres circuits du même type basés sur le composant LM1881 (extracteur de synchro vidéo) qu'on trouve facilement.

Avatar de l’utilisateur
MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 316
Inscription : 06 sept. 2016 13:16

Re: Divers bricolages sur ZX81

Message par MapommeCMOA » 09 déc. 2018 04:24

Bonjour nicolho.
Super ! Merci pour les liens.
Petite bidouille pas compliquée.
Effectivement, comme je l'ai déjà dit, pour moi, l'anglais c'est du chinois, mais je vais me débrouiller. DEEPL est mon ami.
Encore merci et bon dimanche.

nicolho
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 14 sept. 2018 02:06

Re: Divers bricolages sur ZX81

Message par nicolho » 09 déc. 2018 12:08

Avec plaisir ! Je rappelle encore que le circuit proposé précédemment ne concerne que les ZX81 équipés d'un ULA de type C184, le défaut ayant été corrigé dans les versions ultérieures de cette puce (avec lesquelles je ne ne suis pas sûr que cette modif' ferait bon ménage).

Finalement, en faisant un peu le tour des circuits (documentés) à base de LM1881 qui ajoutent aussi le back porch manquant, j'ai retenu ce site de Leandro Novellón qui en présente un qui a l'air bien pensé (ainsi que des circuits d'inversion vidéo) et assorti de quelques précisions intéressantes : http://trastero.speccy.org/cosas/JL/zx8 ... video.html (au cas où tu serais plus à l'aise en espagnol :wink:)
On retrouve le même schéma sur cette page : http://old8bits.blogspot.com/2013/10/mo ... 81-ii.html avec un transistor ajouté pour la sortie vidéo composite, et plus bas propose des valeurs de résistances fixes qui pourraient fonctionner directement.

Avatar de l’utilisateur
MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 316
Inscription : 06 sept. 2016 13:16

Re: Divers bricolages sur ZX81

Message par MapommeCMOA » 09 déc. 2018 15:27

Génial. Je ne manque pas de billes maintenant. J'ai de quoi m'amuser encore un moment.
Le fait d'être cantonné à sa langue maternelle est très handicapant (mais je l'adore).
Lorsque je consulte un site auquel je n'entrave absolument rien, je fais systématiquement un document traduit en mon idiome, mais il comporte sans doute des erreurs, car chaque langue a ses subtilités, qu'un traducteur automatique peut difficilement interpréter.
Je ne le dirai pas assez : Mille fois merci !

Avatar de l’utilisateur
MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 316
Inscription : 06 sept. 2016 13:16

Re: Divers bricolages sur ZX81

Message par MapommeCMOA » 09 déc. 2018 17:44

Voilà une photo du mien.
Est-il concerné par ce mal ?
Image

Avatar de l’utilisateur
MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 316
Inscription : 06 sept. 2016 13:16

Re: Divers bricolages sur ZX81

Message par MapommeCMOA » 09 déc. 2018 21:27

Comme je bricole sur pas mal de choses en même temps, je ne finis rien, mais ça avance doucement.
J'ai quand même fait quelques modifs sur mon ZX81.
Un radiateur sur le ULA. Ça chauffe pas mal ce truc.
Une vue générale du circuit. Les fils jaune et noir, sur le condensateur, au centre, vont sur le contact de reset.
Image

Remplacement du régulateur 5V par un petit convertisseur et ajout d'une LED de présence du 5V
Image

Modification de la mémoire et extension du support (un bouquet de 4 tulipes en plus). Maintenant, il y a 16K en interne. Merci Fabrice pour le lien.
Image

La petite modif pour avoir une sortie vidéo composite (résistance + capa), est maintenant interne au modulateur. L'ancien circuit y est toujours.
Image

Le petit convertisseur DC DC qui remplace le régulateur 5V, vient d'un chargeur allume cigare de téléphone. Ça ne chauffe pas, c'est pas encombrant et ça sort un 5V très stable.
L'électrochimique, est toujours en circuit bien qu'il ne soit plus nécessaire.
Prochaine étape : Remplacement de l'électrochimique et de la résistance (maintenant internes au modulateur) par un circuit plus sérieux et surtout plus efficace.

J'ai fait un clavier avec des touches type "digitast" mais comme ça m'embête de dézinguer le coffret du ZX (j'espère un jour pouvoir mettre un clavier à membrane, moderne), pour le brancher, il faut que je trouve une solution discrète sans ajouter, ni remplacer les connecteurs d'origine.

nicolho
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 14 sept. 2018 02:06

Re: Divers bricolages sur ZX81

Message par nicolho » 10 déc. 2018 08:31

MapommeCMOA a écrit :
09 déc. 2018 17:44
Voilà une photo du mien. Est-il concerné par ce mal ?
Non, ton ULA est communément dénommé le C210 (celui concerné aurait eu le nombre 184 dans sa référence). Donc il génère bien un back-porch et du coup, ce dont j'ai parlé ne concerne pas ta machine (enfin ça resservira peut-être à d'autres, et entretemps j'ai trouvé une autre page super bien illustrée et qui présente une autre méthode, cette fois à base de flip-flops 8) : http://www.victortrucco.com/TK/ZX81Back ... 1Backporch ).

Il fallait commencer par ça, et tu aurais pu déjà nous dire que tu avais déjà modifié ta sortie vidéo... tu parles de "résistance+capa", mais sur la dernière photo, ce serait pas plutôt un (vieux) transistor ? Au moins, stp montre-nous le schéma source, ou explique-nous ce que ça fait (ou bien si ça correspond à ce que je propose juste après), qu'on sache.

Enfin pour l'instant tu devrais peut-être faire tes tests avec la sortie débranchée du modulateur RF, et si ce n'est pas déjà fait, commencer par voir ce que ça donne en ajoutant un transistor, comme expliqué sur cette page : https://www.classic-computers.org.nz/bl ... r-zx81.htm
ou bien comme ceci :
videofix.jpg
videofix.jpg (12.91 Kio) Consulté 258 fois
(quelqu'un a suggéré qu'on puisse ajouter une diode zener entre la sortie et la masse, de 2 ou 2,5 volts comme protection en surtension)

Idéalement, pour trouver la solution la plus adaptée, il faudrait que tu compares le signal en sortie de ton ZX à celui d'un appareil qui fonctionnerait sans problème sur l'entrée composite de ton écran, en essayant de voir quel point serait susceptible d'être amélioré (bruit, niveaux, et les divers timings de synchro horizontale et vertical..).

Après, il est possible de remplacer carrément l'ULA par une création moderne (à base de CPLD ou autre) histoire de se débarrasser une fois pour toute des défauts du signal vidéo des ZX (par exemple viewtopic.php?f=17&t=30626 ) ou plus simplement, de le reconstituer électroniquement, chose relativement abordable vu la nature plutôt "binaire" du signal noir et blanc, par exemple comme ceci, avec un buffer et un LM1881 :
Video-HQPix.gif
source : https://sinclairzxworld.com/viewtopic.php?f=10&t=622&start=20
Video-HQPix.gif (13.47 Kio) Consulté 258 fois
Cet ancien schéma est un des nombreux qu'a proposé son auteur sur le forum sinclairzxworld.com, au gré des révisions de ses différents circuits (ZX-SCP, ZX-CPP, EX-CCB) dont la version la plus récente et aboutie semble être celle-ci : https://www.sellmyretro.com/offer/details/28476
mais plus dispo actuellement, et Pokemon n'a plus posté depuis plusieurs mois... (à voir s'il serait d'accord pour publier le schéma définitif).
Apparemment la dernière version règle un problème avec la lecture et l'enregistrement des cassettes, car comme leur signaux passe par la vidéo (c'est ce qui occasionne toutes les rayures à l'écran pendant ces opérations), dans certains cas les modifications apportées par les correctifs vidéo peuvent les rendre inutilisables.

Enfin je m'arrête là pour passer le relais au vrais ZXistes, et je te souhaite de bonnes bidouilles de fin d'année !

Avatar de l’utilisateur
MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 316
Inscription : 06 sept. 2016 13:16

Re: Divers bricolages sur ZX81

Message par MapommeCMOA » 10 déc. 2018 15:30

Bonjour nicolho, et mille excuses pour l'oubli, mais je pensais qu'en indiquant le fait que je le branche sur l'entrée composite d'une télé, était une information suffisante. :oops:
C'est une petite bidouille volante, que j'avais faite il y a une trentaine d'années. Je l'ai simplement enfermée dans le boîtier du modulateur.
Voilà le schéma :
Image

Le transistor qu'on voit sur la photo rapprochée,Image
est bien d'origine. C'est un 2N2369 (8413) en boîtier TO18, sans doute un équivalent au ZTX 313 habituel (en boîtier plastique SOT 32 (ou TO126)). La seule modif concernant la sortie vidéo, a été l'ajout de la résistance et du condensateur.
Sur un moniteur (celui de l'APPLE II), sur un téléviseur ancienne génération et sur un vieux moniteur vidéo de circuit fermé, l'image est parfaitement stable. Le problème ne se produit que sur un écran moderne (LCD avec entrée composite ou sur prise SCART).
Merci encore de te démener pour moi.

nicolho
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 14 sept. 2018 02:06

Re: Divers bricolages sur ZX81

Message par nicolho » 10 déc. 2018 18:29

Merci, comme je le disais, j'avais remarqué que c'était un transistor sur la même photo (déjà postée plus haut) et c'est pour ça que je précisais "si ce n'est pas déjà fait" en présentant un schéma similaire...

En tout cas, je suis heureux d'apprendre que tu es un bidouilleur de longue date, j'aurais aussi aimé connaître la source de ton schéma, de quel ouvrage il est tiré... On devine que c'est un document d'époque, alors ça fait doucement rigoler (ou grincer des dents) de voir quelqu'un se vanter 30 ans plus tard d'avoir "inventé" exactement le même schéma, présentant des composants absolument identiques (en particulier avec cette référence de transistor depuis longtemps obsolète :lol:) : http://buzz.computer.free.fr/index.php? ... n-for-ZX81

Pour une fois, j'ai eu un peu de mal, mais j'ai finalement trouvé la page 37 de l'édition N°2 du magazine Ordi-5 de janvier 1983 :) qui reproduit précisément la même illustration, et nous en apprend énormément sur certaines particularités de la sortie vidéo du modèle français, je vous en recommande chaudement la lecture dans son intégralité : http://zx81.ordi5.free.fr/n2/download/O ... _02_37.png

(Pour ces histoires de modulation positives et négatives, évoquées dans l'article, j'ai cherché aussi, et j'ai trouvé sur cette page une explication qui m'a plutôt interloquée, voir les 4ème et 5ème figures : http://portelatine.chez-alice.fr/electr ... ision.html )

L'article précise en effet que les composants ("soudés en volant" 8) comme ils disent) qu'on voit sur ta photo serait une modification ajoutée à l'époque "en catastrophe" (par Sir Clive Sinclair lui-même :tongue:) au modèle français pour obtenir une modulation RF adaptée aux téléviseurs de chez nous, alors différente de celle des rosbifs. Et dans la section "Attaque directe d'un moniteur" (d'auto-école ? ok je sors) il est écrit à son propos :
L'adaptation figurant en encadre de la figure 2 permet au ZX81 équipé de son "circuit de francisation" d'attaquer très convenablement une entrée vidéo normalisée 1V 75 ohms.
Du coup, quand tu dis l'avoir "enfermé dans le boîtier du modulateur", je me demande ce que tu as bien pu mettre dedans, tu peux nous montrer ?

Avatar de l’utilisateur
MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 316
Inscription : 06 sept. 2016 13:16

Re: Divers bricolages sur ZX81

Message par MapommeCMOA » 11 déc. 2018 00:52

Re bonjour nicolho
En tout cas, je suis heureux d'apprendre que tu es un bidouilleur de longue date

Oui mais pas de haut vol, c'est le moins qu'on puisse dire. Je sais me servir d'un fer à souder, mais ça ne va pas beaucoup plus loin.
Le bouquin ou j'avais eu le schéma pour modifier la sortie vidéo à l'époque.
Image Image

C'est un petit livre de 128 pages, format 16,5 X 11,6 des éditions (POCHE informatique) ETSF. Je l'ai acheté 30,40F dans les années 80, le prix est toujours dessus. Il a un peu souffert. Il a été édité en 1983 et écrit par Patrick Gueulle, très connu dans les revues de bidouilles électroniques.


Un extrait du passage, page 43, qui concerne la modif en urgence, de Sinclair, pour adaptation au standard Français.
Image

Une vue (un peu floue, faite sans pied) du modulateur ouvert, pour voir la modif.
Image

Le bidule noir, est une résistance ajustable, (isolée avec du thermorétractable) en série sur le condensateur soudé sur la prise RCA. En bas à droite du potar, entre les 2 isolateurs, on voit la résistance (debout) qui était soudée sur la RCA avant modif.
C'est tout bête, ça marche bien sur les anciens moniteurs et TV, mais mal, sur les TV LCD.

nicolho
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 14 sept. 2018 02:06

Re: Divers bricolages sur ZX81

Message par nicolho » 11 déc. 2018 10:13

Oui, en plus des schémas, tu auras certainement remarqué que l'extrait que tu présentes est, mot pour mot, identique aux premiers paragraphes de la page d'ORDI-5 dont j'ai donné le lien, alors rien d'étonnant à se rendre compte que l'article est signé Partrick Gueulle, comme ton bouquin dont je n'ai pas trouvé de reproduction complète en ligne, mais seulement quelques schémas qui en sont issus : http://vesta.homelinux.free.fr/wiki/zx8 ... Gueulle.29

Alors pardon, excuse-moi, ma question était bête, j'ai fini par me mélanger entre la modif française de Sinclair et l'adaptation (dans le rectangle en pointillés) ajoutée par tes soins pour la sortie composite, à savoir le couple "résistance+capa" que tu avais clairement indiqué dès le départ.

Comme expliqué dans l'article, truffé de bonnes informations que je vais citer en italique par la suite (et c'est pourquoi j'en recommandais chaudement la lecture intégrale à tout ZXiste intéressé par le sujet), le transistor britannique ZTX 313 (Ferranti) d'origine sert à la base de simple inverseur (émetteur commun) (https://fr.wikipedia.org/wiki/%C3%89metteur_commun) pour présenter un signal inversé au modulateur sur le collecteur, par contre pour le reste (la sortie "à l'endroit", sur l'émetteur), ça équivaut aux petits schémas habituels de la sortie "transistorisée".

Soit dit en passant, j'ai une pensée émue :mrgreen: :lol: pour tous les bricoleurs qui se sont décarcassés à trouver ce vieux transistor pas courant... parce que les explications accompagnant à l'origine le schéma de Patrick (mais, comme souvent, passées à la trappe par ceux qui ont l'ont mis en ligne) leur auraient appris qu'il "peut être remplacé par tout petit NPN courant, tel que BC 107, 108, 109, 2N 2222, etc..."

Pour t'y mettre, comme je l'ai déjà indiqué, tu pourrais :
- soit pour l'instant ne rien modifier et observer ce que donne ta sortie vidéo à l'oscilloscope, pour voir déjà s'il n'y aurait pas des déviations criantes par rapport à la norme, et après comparer ça avec le signal vidéo composite d'un autre appareil qui fonctionne bien sur ton écran LCD.

- soit (ce qui n'exclut pas la première possibilité, pour arrêter de tâtonner au pif) tenter de mettre en place les circuits que j'avais proposés hier (pas ceux du début pour le back-porch), d'abord en refaisant une simple sortie "transistor+résistance(+condensateur)" sans rien d'autre, puis si ce n'est pas mieux, tenter le circuit de "polissage" du signal, le "CCPIC" de Pokemon reproduit plus haut (celui avec un LM1881 et un buffer 74LS07N)

Dans les deux cas, il faut partir de la sortie patte 16 de l'ULA, mais que tu peux la récupérer aussi ailleurs, soit sur la diode D9 à l'endroit que j'ai entouré ci-dessous, soit au bout de la trace qui sort de cette patte qui doit arriver dans un des trous de soudure sous le modulateur RF (le 3ème en partant du bord je crois, à vérifier, d'ailleurs stp dis nous s'il y a quelque chose de relier dessus). A voir si le "circuit de francisation" n’interfèrerait pas sur le résultat, auquel cas tu pourrais éventuellement le débrancher pour l'instant, par exemple en sortie de l'ULA au niveau de la diode) :
points de contact avec la patte 16 de l'ULA.jpg
points de contact avec la patte 16 de l'ULA.jpg (67.93 Kio) Consulté 149 fois

Avatar de l’utilisateur
MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 316
Inscription : 06 sept. 2016 13:16

Re: Divers bricolages sur ZX81

Message par MapommeCMOA » 11 déc. 2018 14:46

Bonjour
qu'il "peut être remplacé par tout petit NPN courant, tel que BC 107, 108, 109, 2N 2222, etc..."n
Pourtant, il me semble avoir (lu je ne sais plus ou), que si un possesseur de ZX 81 acheté en Angleterre, voulait le "Franciser", il risquait de rencontrer quelques dificultés pour trouver ce fameux transistor et qu'un ZX sans cette modif, ne fonctionnerait pas en France. Maintenant, vu qu'on n'utilise plus le modulateur, est il toujours utile (le transistor)? Si, NON, je vire. Je peux même virer complètement le CI du modulateur. Ça fera de la place dans la boîte, pour ranger une autre éventuelle modif.
Je vais donc débrancher provisoirement ce fameux transistor, retirer l'alim 5V du modulateur et récupérer le signal directement sur la diode (patte 16 de ULA) sur la résistance R32 de 2,2K. ( fais gaffe, tu vas te faire engueuler si tu ne fais pas ce qu'on te dit. C'est dessiné en vert,le signal est à prendre directement sur la patte 16 de ULA
Sur le plot 3 (sous le transistor), il n'y a rien. Ou plutôt si, on dirait qu'il reste un moignon de queue de composant coupé à ras.
Sous le modulateur, il n'y a que les 2 points de soudure à la masse, pour la fixation du boîtier au CI.
Donc, dans l'ordre, en partant du bord, en bas du CI, en remontant (modulateur à gauche), on a :
Plot 1/ Résistance de 150Ω sur émetteur du transo
Plot 2/ Base du transo
Plot 3/ Rien
Plot 4/ Résistance de 170Ω sur collecteur du transo, et entrée du signal (inversé) sur modulateur.
Plot 5/ Entrée du modulateur (alim 5V)
Plot 6/ Vide La piste mène à une pastille vide, sans doute ou un régulateur était prévu pour alimenter seulement le modulateur.
Schéma de la zone concernée.
Image

Je n'ai pas d'oscilloscope, je ne peux donc pas visualiser le signal.
Dernière édition par MapommeCMOA le 11 déc. 2018 17:34, édité 1 fois.

nicolho
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 14 sept. 2018 02:06

Re: Divers bricolages sur ZX81

Message par nicolho » 11 déc. 2018 16:54

MapommeCMOA a écrit :
11 déc. 2018 14:46
Pourtant, il me semble avoir (lu je ne sais plus ou), que si un possesseur de ZX 81 acheté en Angleterre, voulait le "Franciser", il risquait de rencontrer quelques dificultés pour trouver ce fameux transistor et qu'un ZX sans cette modif, ne fonctionnerait pas en France.
Je sais pas, demande à Patrick Gueulle, ça paraît évident que même s'il a écrit un article de 3 pages sur le sujet (avec 100x plus d'informations que les "t'as qu'à" dont on doit se contenter habituellement), il n'y connaît sans doute rien et il a écrit ça pour faire son intéressant..
Je vais (...) récupérer le signal directement sur la diode (patte 16 de ULA) sur la résistance R32 de 2,2K.
Des fois, je me demande pourquoi je me casse la nénette pendant une plombe à dessiner des traits (verts!) sur une de tes photos... R32, c'est déjà plus sur ULA/16 directement, puisqu’il y a la diode D9 entre les deux.. (éventuellement (re)lis le dernier paragraphe de mon dernier message.). Enfin je sais pas, ça n'a peut-être pas trop d'importance, c'était histoire de repartir du plus simple pour essayer les autres circuits.
Sur le plot 3 (sous le transistor), il n'y a rien. Ou plutôt si, on dirait qu'il reste un moignon de queue de composant coupé à ras.
Ça me paraît normal, et comme je voulais te le faire comprendre, c'est que je crois que la trace qui y mène (tu sais la photo de ton ULA, les traits verts que j'ai dessinés par dessus, tout ça..) est reliée directement à ULA/16, c'est pour ça que j'avais marqué "à vérifier" (parce que si c'est le cas, ça te permet aussi de te brancher là pour récupérer ULA/16)
Schéma de la zone concernée.
Oui, on retrouve bien dessus le "circuit de francisation" (dans la zone délimitée par le trait mauve) et au cas où quelqu'un voudrait le consulter en entier sans besoin de nous demander d'où ça vient, voici le lien : http://fetrmartin.free.fr/ZX81/schema_ZX81_Fr.gif
Je n'ai pas d'oscilloscope, je ne peux donc pas visualiser le signal.
Dommage, dans ce cas, difficile de savoir précisément ce qui cloche dans ton signal (enfin pour ton écran LCD) si tu ne peux pas le "voir". Ça me paraît pourtant être un outil très utile pour ces travaux, surtout maintenant que c'est accessible aux électroniciens du dimanche (de 14h30 à 15h personnellement :D), on trouve de vieux oscilloscope d'occasion à moins de 100€, et des modèles numériques low-cost, mais pas mal du tout, sous les 300€ neuf (non, je RIGOL pas ! :lol:)

Répondre

Revenir vers « Sinclair »