KIM-Uno

Modérateur : Politburo

Nikass
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1453
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: KIM-Uno

Message par Nikass » 01 févr. 2019 23:58

euh, beh là t'as pas que ça comme problème, t'as le slash... enfin j'sais pas ce que tu fais avec (le pc de) ta femme moi :-)

bon sérieux dis nous un peu l'environnement de travail pour voir ?

a+

MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 715
Inscription : 06 sept. 2016 13:16

Re: KIM-Uno

Message par MapommeCMOA » 02 févr. 2019 02:07

Bonsoir Nkass.
J'ai déjà compilé et téléversé des trucs avec mon bouzin qu'est sous Linux Mint 18.1 (Serena) Mate (qui est un peu moins gourmand que Cinnamon) à jour et ça marchait très bien, mais c'était des fichiers touts simples. Là c'est un peu plus complexe. Bon, d'accord, c'est pas le dernier modèle, (11 ans pile poil) mais pour ce que je fais avec, ça va très bien.
C'est un Dell inspiron 530s (de récup, que mon voisin foutait à la benne) avec intel Core2 duo, 8Mo de RAM . Tout est d'origine. J'ai juste mis un petit SSD 256 Go pour booster le démarrage et c'est très efficace.
Normalement, vu que l'IDE vient d'un paquet Mint via Synaptic, devrait pas y avoir de problèmes. J'ai désinstallé complètement le paquet et refait une installation complète, mais ça ne change rien. Ah si,maintenant j'ai des messages d'erreur différents.
Mon gouvernement a un portable récent (cadeau des fistons) avec une baie vitrée version 10. Je vais y squatter l'machin. Un IDE ne devrait pas la gêner et ça me dépannera. Je ferai ça demain. Ah, bah on y est déjà. Aujourd'hui alors !

MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 715
Inscription : 06 sept. 2016 13:16

Re: KIM-Uno

Message par MapommeCMOA » 02 févr. 2019 12:13

Ben ça ne va pas mieux. Le programme serait trop gros pour mon Uno (qui me sert de maquette), et les messages sont encore différents. Même sans dé-commenter la ligne qui valide l'affichage sur l'écran OLED, c'est pareil.
Comme ici n'est pas le lieu vraiment adapté pour parler ARDUINO, je vais arrêter de polluer les lieux.
Avé

MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 715
Inscription : 06 sept. 2016 13:16

Re: KIM-Uno

Message par MapommeCMOA » 02 févr. 2019 21:33

Salut à tous.
C'est le sketch qui doit buguer. J'ai essayé avec 2 PC ; 1 avec 7, l'autre avec 10 et ça décarochait toujours. Du coup je suis revenu à mon Nunux et j'ai fait des essais de compilation d'autres programmes. Pas de problème, compil et téléversement vont très bien.
Y a un os dans l'potage et ça dépasse mes compétences, mais c'est une autre histoire.
J'aimerais quand même savoir si Bernouilli92 ou zpalm ont eu le même souci, et si oui, ce qu'ils ont (ou a) fait pour que ça marche. Pour le programme du Kimono, tout se passe très bien. C'est avec UNO1802stm (la dernière version), que ça débloque.
Bise.

Avatar de l’utilisateur
gege
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7196
Inscription : 31 janv. 2008 15:24
Localisation : Banlieue Paârisienne
Contact :

Re: KIM-Uno

Message par gege » 25 oct. 2020 22:11

Bonjour,
En cette époque de vacances, je retrouve ce truc sympa.
Avez-vous fait des choses avec ?
Merci pour vos idées / lumières.
G.E.

MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 715
Inscription : 06 sept. 2016 13:16

Re: KIM-Uno

Message par MapommeCMOA » 27 oct. 2020 12:53

Bonjour
Bonne idée, d'avoir relancé ce sujet.
Le KIM UNO fonctionne, mais je l'avais complètement oublié. J'ai fait un coffret type calculatrice en impression 3D, mais les boutons sont trop bas. Je devais revoir le fichier pour les modifier, mais des travaux plus urgents m'ont occupé un bon moment. Faut que je m'y remette.
J'ai aussi fait la version ELF UNO, mais j'ai eu un souci avec le sketch. J'ai laissé tomber.

MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 715
Inscription : 06 sept. 2016 13:16

Re: KIM-Uno

Message par MapommeCMOA » 11 nov. 2020 22:00

Quelques photos du Uno après modification des STL.
Boîtier et touches après impression
Image
Le Uno fini
Image
Image
Image
Le Uno à côté du vrai KIM1
Image
Des petites choses demandent à être améliorées, mais pour ça, il me faudrait une imprimante plus précise. Je suis quand même assez contant de ce que j'arrive à faire avec ma petite A8.
Ah j'oubliais; le Uno fonctionne très bien.

Avatar de l’utilisateur
steste
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 710
Inscription : 18 sept. 2015 18:59

Re: KIM-Uno

Message par steste » 11 nov. 2020 23:01

Excellent !

Plus qu'a te lancer
dans les méandres de
l'assembleur, avec un afficheur
pareil, c'est coton...

Magnifique machine qui fait
penser que les imprimantes 3d
(et toi) peuvent faire des miracles.

a+, st

Avatar de l’utilisateur
bernouilli92
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 4890
Inscription : 21 nov. 2012 14:03
Localisation : Ile de France

Re: KIM-Uno

Message par bernouilli92 » 12 nov. 2020 00:20

C’est plutôt bien réussi. Les touches aussi ont été imprimées?
Mais pourquoi se faire un kim uno quand on a un kim-1?
C’est vrai qu’il est beaucoup plus petit, un kim de voyage en sorte.
Dernière édition par bernouilli92 le 12 nov. 2020 01:02, édité 1 fois.
HP, Casio, Sharp, Psion, quelques TI et divers autres

MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 715
Inscription : 06 sept. 2016 13:16

Re: KIM-Uno

Message par MapommeCMOA » 12 nov. 2020 01:00

Plus qu'a te lancer
dans les méandres de
l'assembleur, avec un afficheur
pareil, c'est coton...
Ouaip!, mais la, c'est pas gagné vu mon niveau.
C’est plutôt bien réussi. Les touchés aussi ont été imprimée?
Merci.
Oui, les caractères sont imprimés en relief avec les boutons. Le PLA étant blanc,après peinture j'ai passé un coup de 600 à l'eau, ce qui a fait ressortir les chiffres en blanc. Mais ça pourrait être mieux. Le coffret est un peu trop carré et les chiffres manquent de précision.
Mais pourquoi se faire un kim uno quand on a un kim-1?
Le KIM1 est un papy et ça m'embêterait de le traiter comme un gamin. En plus, vu les conneries que je risque d'y faire ingurgiter (je suis complètement nul en prog), ça ne serait pas très respectueux. J'avais commencé à lui faire un coffret pour le mettre en valeur et lui ajouter des bricoles, mais, ça fait partie de choses à finir. Et y en a un paquet.
C’est vrai qu’il est beaucoup plus petit, un kim de voyage en sorte.
Oui, le KIM1 au lit avant de dormir :-))... surtout avec l'alim d'époque, qui doit peser dans les 3kg. Le UNO est gros comme une calculatrice.

Avatar de l’utilisateur
Marge
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 5626
Inscription : 01 oct. 2008 14:39
Localisation : En bas, tout au fond à gauche.

Re: KIM-Uno

Message par Marge » 12 nov. 2020 03:12

C'est un beau travail, bravo ! J'imagine qu'on n'arrive pas à la perfection dès le départ avec la 3D... ça me plaît bien.
(Je ne t'oublie pas pour les J&S, mais c'est un peu coincé en ce moment...)
3 hommes, 3 demis, un 3a... Magnéto, Serge !

« Boris », c'est juste Maurice enrhumé.

MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 715
Inscription : 06 sept. 2016 13:16

Re: KIM-Uno

Message par MapommeCMOA » 12 nov. 2020 13:30

Pas de souci pour les revues, elles attendent sagement.

Avatar de l’utilisateur
F5PBL
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 15
Inscription : 16 févr. 2021 13:32

Re: KIM-Uno

Message par F5PBL » 17 févr. 2021 14:11

Bonjour à tous,

Je sort ma pelle pour déterrer le sujet. Enfin, novembre 2020 ce n'est pas si vieux non plus !
L'été dernier, il y a eu une mise à jour du logiciel, qui permet maintenant d'émuler un Apple I pour le même prix. Et on peut maintenant aussi téléverser tout cela sur STM32 ("blue pill") ou ESP32. Cf. https://obsolescence.wixsite.com/obsole ... no-details

@MapommeCMOA : comment as-tu résolu ton soucis de compilation ? Cela pourrait servir à la postérité :)
Et félicitations pour le boîtier, cela donne un fini superclasse au montage !
Claude

MapommeCMOA
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 715
Inscription : 06 sept. 2016 13:16

Re: KIM-Uno

Message par MapommeCMOA » 18 févr. 2021 14:37

Bonjour F5PBL.
Merci mais c'est pas parfait.
Pour le Elf Uno, j'avoue ne pas m'être intéressé au problème depuis mon dernier post sur le sujet.
Avec l'ajout des nouvelles extensions (par obsolescence), je vais sans doute revoir la chose.
Je n'ai pas trouvé d'adepte de ce montage ("quelqu'un qui s'y connaît"... pas comme moi), pour savoir comment il avait procédé, ou pour me dire ou je me suis planté, dans mes tentatives de compilation. Il doit y avoir un conflit quelque part, je pense. La mémoire de l’Arduino micro est peut être trop petite.
En tout cas, j'ai fait un STL spécifique du boîtier avec écran pour l'Elf Uno, mais pas prévu pour le clavier d'origine. J'ai fait un clavier additionnel en sandwich sur la carte principale (faut que je le retrouve). Ça au moins, ça ne me pose pas de problème.

Avatar de l’utilisateur
F5PBL
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 15
Inscription : 16 févr. 2021 13:32

Re: KIM-Uno

Message par F5PBL » 21 févr. 2021 20:45

Bonsoir MapommeCMOA (j'adore ce pseudo ! :mrgreen: ),

Je suis moi aussi en train de me battre pour arriver à compiler la toute dernière version du code dispo sur le site du Kim-Uno.
Les bibliothèques ont pas mal évolué et je ne suis pas certain de la retro-compatibilité.
La version sur le site d'Obsolescence est datée du 17 août 2020 et malgré cela, il y a déjà de .. l'obsolescence.
Plutôt que de réinventer l'eau chaude, je compte contacter l'auteur directement, cela sera mille fois plus efficace. :lol:
Claude

Répondre

Revenir vers « Les Single Board Computers (SBC) »