Page 2 sur 4

Re: Aigle d'or qui ne se lance pas

Publié : 19 mars 2020 18:26
par ckl67
C'est rassurant de savoir qu'avec le format de conversion ajoutant du silence à la fin, cela fonctionne :D

Concernant le mode stéréo.
C'est bien ce que j'ai fait.
Le fichier .wav est mono, et j'ai rassemblé gauche et droite pour aller sur l'entrée de l'Oric
oric-tap-format-1.png
oric-tap-format-1.png (46.23 Kio) Consulté 1111 fois
Un moment je me suis même demandé, si le problème ne pouvait pas venir de là..

Je vais commencer à retravailler mon câble.
Le raccourcir, et faire plusieurs essais.

Re: Aigle d'or qui ne se lance pas

Publié : 19 mars 2020 18:28
par ckl67
gleike a écrit :
19 mars 2020 16:58
Tu ne veut pas plutôt investir dans un Erebus, voir ici :http://www.silicium.org/forum/viewtopic ... lit=erebus
avec lui plus de problème de chargement des fichiers TAP.
le prix du montage est modique.
Merci pour l'info. :D :D :D :D :D

Je vais certainement suivre cette voie.

Néanmoins, j'aurais bien voulu comprendre pourquoi cela ne fonctionne pas avec les fichiers .wav.

A l'époque j'arrivais bien à charger des jeux à travers cassettes ..

Je vais faire encore quelques modifications sur le câble, ou attende d'avoir réceptionner mon câble audio et refaire un test..
Une certaine nostalgie de pouvoir passer par un fichier audio..

Si par la suite cela ne fonctionne toujours pas je vais opter pour Erebus

Encore merci pour l'info

Re: Aigle d'or qui ne se lance pas

Publié : 19 mars 2020 19:46
par gleike
mandrake a écrit :
19 mars 2020 18:08
j'ai voulu en acheté un sur Ebay mes les 80 exemplaires sont vendus
https://www.ebay.fr/itm/Erebus-Oric-Atm ... 4120579582
Houla, 50€ pour un Erebus avec le port c'est horriblement cher 8O
en le faisant moi même il m'a coûté à peine une douzaine d'euro,
Il n'y a presque pas de composants, 5 CI logiques et une Eprom.

Bon c'est vrai que j'avais quelque pièces en stocks, mais pas pour un différence de 38€

Re: Aigle d'or qui ne se lance pas

Publié : 19 mars 2020 20:09
par Ythunder
Mais alors pourquoi donc, les gens notamment sur ce forum, indique que "ça vaut le prix que tu veux bien y mettre ?"
.....

Re: Aigle d'or qui ne se lance pas

Publié : 20 mars 2020 13:10
par Papa13
Bonjour, à propos d’Erebus, si quelqu’un pouvais avoir la gentillesse de me répondre :D http://www.silicium.org/forum/viewtopic ... lit=erebus
Merci. :wink:

Re: Aigle d'or qui ne se lance pas

Publié : 20 mars 2020 18:43
par Hobiecat
C'est surtout d'une extrême facilité d'utilisation : on met le fichier sur la carte sd, on démarre l'Oric et hop quasiment instantanément, ça fonctionne. Pas besoin d'attendre la cassette où je ne sais quelle conversion.

Re: Aigle d'or qui ne se lance pas

Publié : 20 mars 2020 23:01
par ckl67
Bon ben ça ne marche toujours pas chez moi. :cry: :cry: :cry: :cry: :cry:
J'ai raccourci mon câble, j'ai refait la soudure, et le jeux ne se lance toujours pas .. :oops:

Une fois le premier niveau de chargement passé (Aigle ..1) , ou l'on appui sur la barre d'espace pour avoir les instructions du jeux, la deuxième partie commence son téléchargement, et puis arrivé à la fin de la lecture du fichier .wav, "RIEN" :cry: l'ATMOS ne répond plus. :cry:

C'est incompréhensible..
La dernière solution (avant de basculer sur l'Erebus) attendre la réception de mon câble audio.

Ne comprends pas ne comprends pas :?: :?: :?:

Re: Aigle d'or qui ne se lance pas

Publié : 21 mars 2020 14:14
par mandrake
Tu as testé avec un jeu qui n'est pas en plusieurs parties ?

Re: Aigle d'or qui ne se lance pas

Publié : 23 mars 2020 11:59
par ckl67
Oui, j'en ai testé 2, 3 au hasard qui fonctionnent.
Jeux de balle, Chess...
IMG-3054.jpg
IMG-3054.jpg (153.87 Kio) Consulté 1034 fois



Mais aigle d'or ne veut pas .. :cry:

Re: Aigle d'or qui ne se lance pas

Publié : 23 mars 2020 13:09
par gilles
c'est peut être une question de temporisation entre les fichiers présents dans le WAV.
Sur une image .tap les temporisations sont souvent absentes. Les utilitaires vont parfois créer des temporisation, mais c'est parfois insuffisant.
il faudrait sans doute découper en plusieurs fichier WAV (ou bloquer la lecture) et ne passer au suivant que lorsque le programme est vraiment en train d'attendre la suite.

Re: Aigle d'or qui ne se lance pas

Publié : 23 mars 2020 14:21
par Ythunder
Le jeu d'échec est très beau

Re: Aigle d'or qui ne se lance pas

Publié : 23 mars 2020 15:41
par mandrake
Il y avait un programme pour décortiqué ce genre de fichier mais il est devenu introuvable :roll:
http://andre.cheramy.net/telechargement ... plorer.pdf

Re: Aigle d'or qui ne se lance pas

Publié : 23 mars 2020 20:36
par ckl67
gilles a écrit :
23 mars 2020 13:09
c'est peut être une question de temporisation entre les fichiers présents dans le WAV.
Je vais essayer d'adapter la conversion tap2wav dans ce sens.

Re: Aigle d'or qui ne se lance pas

Publié : 23 mars 2020 21:02
par ckl67
mandrake a écrit :
23 mars 2020 15:41
il semblerait qu'il y ai trois parties dans le fichier je l'ai découpé
Je vais essayer demain, et revenir vers vous.
Par contre, c'est vraiment étonnant qu'il y a 3 parties.
En tous les cas dans le fichier .TAP que j'ai, il n'y a que 2 parties..

En se basant sur le format .TAP qui est l'image stockée dans la mémoire ORIC,
oric-tap-format.png
oric-tap-format.png (152.17 Kio) Consulté 997 fois
Chaque nouvelle section commence avec une sécance 0X16 0X16 0X24.
Il suffit de prendre un éditeur de texte qui affiche en Hexa, et tu trouves qu'il n'y a que deux parties distinctes.
Capture.PNG
Capture.PNG (36.28 Kio) Consulté 997 fois
Capture1.PNG
Capture1.PNG (23.69 Kio) Consulté 997 fois
A moins que le fichier .TAP ait un soucis... Je vérifie et vous tiens au courant.

Re: Aigle d'or qui ne se lance pas

Publié : 24 mars 2020 11:49
par mandrake
je viens d'essayer en trois parties cela ne marche pas (les deux premières parties sont en continus malgré le début de fichier annoncé (bruit continu))
En définitif :
La première partie dure 1'46"
La seconde partie dure 4'46"

Donc coupé en deux ça marche, testé et approuvé !!!! :
https://we.tl/t-pX4lU2US85