Lancement Aigle d'or à travers fichier .wav résolu

Tous les Orics (bon y en a pas des masses, mais on nous l'a demandé gentillement)

Modérateur : Politburo

ckl67
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 12 mars 2020 11:38

Lancement Aigle d'or à travers fichier .wav résolu

Message par ckl67 » 12 mars 2020 11:51

Bonjour à tous

Mon soucis:
Oric Atmos que j'ai ressorti de mes cartons, et qui tourne à merveille :wink:

J'ai récupéré des fichiers TAP que je transforme avec l'utilitaire TAP2wav en fichier audio, et que je transferts par la suite vers l'ORIC Atmos.
J'ai fait le test avec plusieurs conversion TAP --> wav et cela fonctionne plutôt bien.

Malheureusement cela ne fonctionne pas avec mon Jeu favori de l'époque "l'aigle d'or" :oops: :oops:

Le même fichier tap de "l'aigle d'or" tourne sur l'émulation Euphoric, mais sur la machine hardware, le jeu ne veux pas démarrer.
Il charge bien, mais à la dernière étape, il reste dans l'état "Chargement du Programme"
Je n'ai pas l'invite pour entrer le nom du joueur.
J'ai beau appuyer sur toutes les touches , l'oric ne répond plus .. :oops:
Voir image ci-dessous

Est-ce que ce problème vous parle ?

A l'époque avec la cassette j'arrivais bien à jouer avec "l'aigle d'or" sur ma machine ..
Avez-vous rencontré ce type de soucis ??

Milles merci si vous pouviez m'aiguiller sur la solution.
ao1.jpg
ao1.jpg (39.04 Kio) Consulté 2855 fois
ao2.jpg
ao2.jpg (55.06 Kio) Consulté 2855 fois
Cordialement

Christian
Dernière édition par ckl67 le 01 avr. 2020 12:12, édité 1 fois.

Ben
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1743
Inscription : 21 août 2016 19:04

Re: Aigle d'or qui ne se lance pas

Message par Ben » 12 mars 2020 12:30

Ce n'est pas un problème du fichier WAV? Tu le transferts sur une cassette audio ou tu le lis directement à partir d'un PC?

ckl67
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 12 mars 2020 11:38

Re: Aigle d'or qui ne se lance pas

Message par ckl67 » 12 mars 2020 12:48

Je le transferts du PC vers mon Oric après conversion TAP --> Wav
Cable PC --> ORIC

Comme je le fais d'ailleurs avec d'autres fichiers.. ou cela fonctionne.

ckl67
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 12 mars 2020 11:38

Re: Aigle d'or qui ne se lance pas

Message par ckl67 » 12 mars 2020 14:01

Du coup je suis en train de me demander si cela ne viendrait pas d'autre chose..
Cable, signal trop fort..

Je viens d'essayer avec un autre jeu "Le diamant de l'île maudite" et pareil..

Pourtant sur des jeux simples comme Zebulon, le transfert fonctionne

Je retourne faire des tests
..

Avatar de l’utilisateur
Pocket
Administrateur
Administrateur
Messages : 5667
Inscription : 24 mai 2002 16:55
Localisation : Toulouse
Contact :

Re: Aigle d'or qui ne se lance pas

Message par Pocket » 12 mars 2020 14:38

Salut,

Oui faire des tests à différents niveau de sortie audio, ça peut jouer.

A+
Pocket, voit tout, sait tout, lit l'avenir dans les entrailles d'une base phpBB ...
Image

Avatar de l’utilisateur
gleike
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 168
Inscription : 13 déc. 2014 20:06
Localisation : Ludres (54710)

Re: Aigle d'or qui ne se lance pas

Message par gleike » 12 mars 2020 16:10

j'ai eu le même problème, cela viens de l'utilitaire Tap2wav qui ne laisse pas assez
de signal de sortie à la fin du fichier wav après la conversion,
je l'ai modifié en conséquence,
le voici en version corrigé qui fonctionne pour moi : https://www.partage-temporaire.fr/2020/03/12/tap2wav2/

ckl67
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 12 mars 2020 11:38

Re: Aigle d'or qui ne se lance pas

Message par ckl67 » 12 mars 2020 19:38

Merci pour ta réponse.

OK, je viens de comprendre, tu as ajouté une palanqué de zéro à la fin du fichier.. 0x80
C'est étonnant que cela puisse avoir une incidence..

Je vais essayer ça..

Merci

ckl67
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 12 mars 2020 11:38

Re: Aigle d'or qui ne se lance pas

Message par ckl67 » 16 mars 2020 16:05

Cela ne marche toujours pas :? :cry:
Toujours le même phénomène..
J'ai beau essayer tous les niveaux, mais le jeu ne veux pas se lancer.
Il charge bien, mais reste bloquer par la suite.
Le clavier ne répond plus..

Est-ce que qu'un veut bien essayer mon fichier svp ?

https://drive.google.com/file/d/1iqCaEG ... sp=sharing

Merci d'avance

Christian

Avatar de l’utilisateur
mandrake
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 2337
Inscription : 27 avr. 2006 22:41
Localisation : Chateauneuf les Martigues en face d'Ajaccio
Contact :

Re: Aigle d'or qui ne se lance pas

Message par mandrake » 18 mars 2020 10:55

gleike a écrit :
12 mars 2020 16:10
j'ai eu le même problème, cela viens de l'utilitaire Tap2wav qui ne laisse pas assez
de signal de sortie à la fin du fichier wav après la conversion,
je l'ai modifié en conséquence,
le voici en version corrigé qui fonctionne pour moi : https://www.partage-temporaire.fr/2020/03/12/tap2wav2/
idem chez moi aucun wav ne se lançaient après conversion comme si ils attendaient quelques données de fin, mais en relisant quelques secondes le début du fichier le jeux se lance, je veux bien la version corrigé de tap2wav (plus disponible sur le partage).
c'est le même problème sur tap2cd ?
Merci
Rien n'est jamais perdu, tant qu'il reste quelque chose à trouver. (pierre DAC)
Ressources pour TI-99/4A et 4 tout court

Avatar de l’utilisateur
gleike
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 168
Inscription : 13 déc. 2014 20:06
Localisation : Ludres (54710)

Re: Aigle d'or qui ne se lance pas

Message par gleike » 18 mars 2020 13:19

Voiçi le nouveau lien pour Tap2Wav version corrigé: http://www.okok.fr/informations-fichier ... e61e45b085

Pour Tap2CD je ne sais pas, je ne l'ai jamais utilisé.

ckl67
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 12 mars 2020 11:38

Re: Aigle d'or qui ne se lance pas

Message par ckl67 » 18 mars 2020 14:28

mandrake a écrit :
18 mars 2020 10:55
en relisant quelques secondes le début du fichier le jeux se lance
Que veux-tu dire par la?

ckl67
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 12 mars 2020 11:38

Re: Aigle d'or qui ne se lance pas

Message par ckl67 » 18 mars 2020 14:29

gleike a écrit :
18 mars 2020 13:19
Voiçi le nouveau lien pour Tap2Wav version corrigé: http://www.okok.fr/informations-fichier ... e61e45b085

Pour Tap2CD je ne sais pas, je ne l'ai jamais utilisé.
Ok je teste et reviens vers vous.
Merci

ckl67
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 29
Inscription : 12 mars 2020 11:38

Re: Aigle d'or qui ne se lance pas

Message par ckl67 » 19 mars 2020 15:44

Hello,

Me voici de retour.
Eh ben cela ne marche toujours pas chez moi :cry:
Je ne suis pas étonné.. :oops:
gleike a écrit :
18 mars 2020 13:19
version corrigé: Tap2Wav
En fait je n'ai pas de changement au niveau de la conversion tap2wav depuis l'essai fait avec ton premier lien fourni le 12 mars 2020 15:10.

De quatre choses l'une.
  • Soit mon Oric est HS.
    • Je n'y crois pas trop, sinon, il ne passerait pas la premier étape de chargement (Aigle D'or 1)
  • Soit mon fichier .TAP n'est pas bon
    • Je n'y crois pas trop non plus, j'ai essayé plusieurs fichiers
    • Éventuellement si quelqu'un avait l'amabilité de tester mes fichiers .wav et me faire un retour. :D
  • Soit mon câble audio entre mon PC et Oric est pourri..
    • Forte probabilité ici, celui que j'ai fait 1,5m, et fabriqué moi-même ..
    • J'en ai commandé un nouveau, je serai fixé là dessus par après
  • Niveau Audio pas bon
    • La aussi je suis sceptique, cela passe pour la première partie de l'aigle d'OR, mais bloque une fois le téléchargement fini
Voilà voili pour mes investigations.

Merci d'avance pour votre aide et conseils. s'il y en a encore :roll: :roll:

Cdt.
Christian

Avatar de l’utilisateur
gleike
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 168
Inscription : 13 déc. 2014 20:06
Localisation : Ludres (54710)

Re: Aigle d'or qui ne se lance pas

Message par gleike » 19 mars 2020 16:58

Tu ne veut pas plutôt investir dans un Erebus, voir ici :http://www.silicium.org/forum/viewtopic ... lit=erebus
avec lui plus de problème de chargement des fichiers TAP.
le prix du montage est modique.

Avatar de l’utilisateur
mandrake
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 2337
Inscription : 27 avr. 2006 22:41
Localisation : Chateauneuf les Martigues en face d'Ajaccio
Contact :

Re: Aigle d'or qui ne se lance pas

Message par mandrake » 19 mars 2020 18:08

ckl67 a écrit :
19 mars 2020 15:44
.....
[*]Soit mon câble audio entre mon PC et Oric est pourri..
  • Forte probabilité ici, celui que j'ai fait 1,5m, et fabriqué moi-même
Tap2wav2 fonctionne chez moi et corrige en effet le blocage de fin de fichier, auparavant avec l'ancienne version je lisais mon fichier et arrivé a la fin le loading était toujours affiché, je relançais la lecture de mon fichier du début quelques secondes pour que le jeux se lance enfin.
Cela doit être ton câble, as tu pris en compte que le signal sur le PC est en stéréo et sur l'Oric en Mono ?
Le jack côté PC est stéréo je suppose et coté Oric tu as un jack mono ?
Il faut mélanger les deux signaux stéréo en provenance du PC pour les diriger sur l'Oric sur la DIN MONO
Image
pour le niveau son général côté PC 80% et sur le lecteur audio 50% chez moi
gleike a écrit :
19 mars 2020 16:58
Tu ne veut pas plutôt investir dans un Erebus, voir ici :http://www.silicium.org/forum/viewtopic ... lit=erebus
avec lui plus de problème de chargement des fichiers TAP.
le prix du montage est modique.
j'ai voulu en acheté un sur Ebay mes les 80 exemplaires sont vendus
https://www.ebay.fr/itm/Erebus-Oric-Atm ... 4120579582
et j'ai deux mains gauches pour faire le montage moi même :geek:
Dernière édition par mandrake le 26 oct. 2020 09:00, édité 1 fois.
Rien n'est jamais perdu, tant qu'il reste quelque chose à trouver. (pierre DAC)
Ressources pour TI-99/4A et 4 tout court

Répondre

Revenir vers « Oric »